Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

You need the CODESYS programming environment version 3.5 in order to be able to use Raspberry. You can download this free of charge from the CODESYS store

http://store.codesys.com/engineering/codesys.html

...

If you don't have an image, it can be downloaded from http://www.raspberrypi.org/downloads. You then have to flash it to the SD card.

Activation of SSH

Info

Activate SSH:

https://www.raspberrypi.org/

...

documentation/

...

remote-access/

...

ssh/
http://forum.codesys.com/viewtopic.php?f=22&t=6345&p=12781#p12781

...


Tip

If you already use the Raspberry Pi for other things, you can of course continue to use your existing image.

The CODESYS PLC is installed via the following menu item:

Info

The Raspberry Pi must be located in the same network as the CODESYS PC from which the installation is executed.

You can now scan the Raspberry Pi in your network. All the Raspberry Pi devices in this network appear in the scan.

 

Info

Login data

User name:  pi
Password:

...

   raspberry

 

The Debian package from the store download is now installed on the Raspberry Pi and the PLC is also started directly. The message Update finished in the window Messages -> RaspberryPI indicates a successful installation.  

...

You can use the following fieldbuses / features with the Raspberry Pi:

  • EtherCAT master
  • Profinet mastercontroller / Profinet device
  • Modbus TCP / master, slave
  • Modbus RTU / master, slave
  • Ethernet/IP scanner and adapter
  • CANopen over EL6751 gateway terminal

...